VCOM:VectorWorks:ISDK::InsertObjectAfter

From Vectorworks Developer
Jump to navigation Jump to search

.SDK|SDK ..SDK:Types|SDK Types ..VCOM:VCOM (Vectorworks Component Object Model)|VCOM Basics ..VCOM:Class Reference|VCOM Class Reference

Description

namespace VectorWorks

Member of VCOM:VectorWorks:ISDK

Unlinks h from wherever it currently is in the drawing and inserts it immediately after afterObject. Any changes in drawing order can be accomplished using this routine or its companion InsertObjectBefore. For example, to implement the 'Move Foward' command, you would use 'InsertObjectAfter(cbp, h, NextObject(cbp, h))'. You can also use InsertObjectAfter to move objects in to and out of containers - see InsertObjectBefore for an example of this.

virtual void InsertObjectAfter(
MCObjectHandle h,
MCObjectHandle afterObject)

Parameters

MCObjectHandle h No information available.
MCObjectHandle afterObject No information available.

Version

Availability: from Vectorworks 2009