VCOM:VectorWorks:ISDK::InsertNewDLComponent

From Vectorworks Developer
Jump to navigation Jump to search

.SDK|SDK ..SDK:Types|SDK Types ..VCOM:VCOM (Vectorworks Component Object Model)|VCOM Basics ..VCOM:Class Reference|VCOM Class Reference

Description

namespace VectorWorks

Member of VCOM:VectorWorks:ISDK

Inserts a new component before index in the Double Line Preferences.

virtual CBbool InsertNewDLComponent(
Sint16 beforeIndex,
WorldCoord width,
long fill,
Uint8 penWeightLeft,
Uint8 penWeightRight,
Sint8 penStyleLeft,
Sint8 penStyleRight)

Parameters

Sint16 beforeIndex No information available.
WorldCoord width No information available.
long fill No information available.
Uint8 penWeightLeft No information available.
Uint8 penWeightRight No information available.
Sint8 penStyleLeft No information available.
Sint8 penStyleRight No information available.

Return Value

On error returns: false

Version

Availability: from Vectorworks 2009