VCOM:VectorWorks:ISDK::Insert3DVertex

From Vectorworks Developer
Jump to navigation Jump to search

.SDK|SDK ..SDK:Types|SDK Types ..VCOM:VCOM (Vectorworks Component Object Model)|VCOM Basics ..VCOM:Class Reference|VCOM Class Reference

Description

namespace VectorWorks

Member of VCOM:VectorWorks:ISDK

Inserts a new vertex of type t into the specified 3D polygon. Existing vertices are numbered starting from 1; set beforeVertex to 1 to insert the new vertex before the first vertex, set it to one greater than the last vertex (i.e. CountVertices(cbp, h) + 1) to insert the new point as the last vertex. If recalcBounds is false, the bounding box of the poly is not recalculated to reflect the changed coordinate values. This is useful when you are changing many points of a polygon (call ResetObject when you have finished).

virtual void Insert3DVertex(
MCObjectHandle h,
const WorldPt3& p,
short beforeVertex,
bool recalcBounds = true)

Parameters

MCObjectHandle h No information available.
constWorldPt3& p No information available.
short beforeVertex No information available.
boolrecalcBounds= true No information available.

Version

Availability: from Vectorworks 2009