VCOM:VectorWorks:ISDK::ImportDXF

From Vectorworks Developer
Jump to navigation Jump to search

.SDK|SDK ..SDK:Types|SDK Types ..VCOM:VCOM (Vectorworks Component Object Model)|VCOM Basics ..VCOM:Class Reference|VCOM Class Reference

Description

namespace VectorWorks

Member of VCOM:VectorWorks:ISDK

The DXF or DWG file specified by the file identifier pFileID is imported into the currently active document.

No dialogs come up except for the progress dialog, which allows the user to cancel.

GetProgramVariable() and SetProgramVariable() can be used to control the settings that would normally be set in the import dialog or to get info about the import after it has completed.

SetDXFColorToLineWeight() and GetDXFColorToLineWeight() can be used to set and view the current color to lineweight mapping for import.

virtual short ImportDXF(
IFileIdentifier* pFileID)

Parameters

pFileID IFileIdentifier* The file that is to be imported.

Return Value

On error returns: false

Version

Availability: from Vectorworks 2009