VCOM:VectorWorks:ISDK::GetWorksheetCellNumberFormat

From Vectorworks Developer
Jump to navigation Jump to search

.SDK|SDK ..SDK:Types|SDK Types ..VCOM:VCOM (Vectorworks Component Object Model)|VCOM Basics ..VCOM:Class Reference|VCOM Class Reference

Description

namespace VectorWorks

Member of VCOM:VectorWorks:ISDK

Gets the specified worksheet cell's number format.


Number Format constants:

name value meaning of accuracy

nsGeneral = 0

nsFixDecimal = 1 number of decimal places

nsDecwCommas = 2 number of decimal places

nsScientific = 3 number of decimal places

nsFractional = 4 largest displayed denominator

nsDimension = 5

nsAngle = 6 corresponds to angular accuracy in units dialog

nsDate = 7

nsConditonal = 8

virtual void GetWorksheetCellNumberFormat(
MCObjectHandle worksheet,
const Point& cell,
short& style,
short& accuracy,
const TXString& leaderString,
const TXString& trailerString)

Parameters

MCObjectHandle worksheet No information available.
constPoint& cell No information available.
short& style No information available.
short& accuracy No information available.
constTXString& leaderString No information available.
constTXString& trailerString No information available.

Version

Availability: from Vectorworks 2009