VCOM:VectorWorks:ISDK::GetVertex

From Vectorworks Developer
Jump to navigation Jump to search

.SDK|SDK ..SDK:Types|SDK Types ..VCOM:VCOM (Vectorworks Component Object Model)|VCOM Basics ..VCOM:Class Reference|VCOM Class Reference

Description

namespace VectorWorks

Member of VCOM:VectorWorks:ISDK

Sets vertex to the vertexNum'th vertex of h and vType to the corner type. vType always equals vtCorner for a polygon. Vertices are numbered starting from 1 up to CountVertices(h). If vertexNum is outside the defined range, GetVertex will return the point {0, 0} and vtCorner.

virtual void GetVertex(
MCObjectHandle h,
short vertexNum,
WorldPt& vertex,
VertexType& vType,
WorldCoord& arcRadius)

Parameters

MCObjectHandle h No information available.
short vertexNum No information available.
WorldPt& vertex No information available.
VertexType& vType No information available.
WorldCoord& arcRadius No information available.

Version

Availability: from Vectorworks 2009