VCOM:VectorWorks:ISDK::GetTextVerticalSpacing

From Vectorworks Developer
Jump to navigation Jump to search

.SDK|SDK ..SDK:Types|SDK Types ..VCOM:VCOM (Vectorworks Component Object Model)|VCOM Basics ..VCOM:Class Reference|VCOM Class Reference

Description

namespace VectorWorks

Member of VCOM:VectorWorks:ISDK

Gets the spacing of the entire text block. which can be:


kTextCustomLeading = 0,

kTextSingle = 2,

kTextThreeHalves = 3,

kTextDouble = 4


If spacing is kTextCustomLeading, then height is set to the custom leading value. Otherwise height is unchanged.

virtual void GetTextVerticalSpacing(
MCObjectHandle textBlock,
short& spacing,
WorldCoord& height)

Parameters

MCObjectHandle textBlock No information available.
short& spacing No information available.
WorldCoord& height No information available.

Version

Availability: from Vectorworks 2009