VCOM:VectorWorks:ISDK::GetSelectionBounds

From Vectorworks Developer
Jump to navigation Jump to search

.SDK|SDK ..SDK:Types|SDK Types ..VCOM:VCOM (Vectorworks Component Object Model)|VCOM Basics ..VCOM:Class Reference|VCOM Class Reference

Description

namespace VectorWorks

Member of VCOM:VectorWorks:ISDK

Returns in bounds the smallest CoordRect that completely surrounds the selection. For an object like a locus, the value depends on the type: kGeometricBounds will just give the point the locus is at, while kRefreshBounds will give the rectangle that encloses what is drawn on screen to represent the locus.

virtual void GetSelectionBounds(
WorldRect& bounds,
BoundsType type = kRefreshBounds)

Parameters

WorldRect& bounds No information available.
BoundsTypetype= kRefreshBounds No information available.

Version

Availability: from Vectorworks 2009