VCOM:VectorWorks:ISDK::GetSelChoiceIndex

From Vectorworks Developer
Jump to navigation Jump to search

.SDK|SDK ..SDK:Types|SDK Types ..VCOM:VCOM (Vectorworks Component Object Model)|VCOM Basics ..VCOM:Class Reference|VCOM Class Reference

Description

namespace VectorWorks

Member of VCOM:VectorWorks:ISDK

Returns the selected value in a choice item. inStartIndex is where to start looking. It will return the value index (choiceNumber) or -1 if no selection is found.


[jag 2-8-99] GetSelChoice now works with list boxes. Since list boxes can support multiple selections, GetSelChoice can be called repeatedly to retrieve all selections. Pass 0 for atChoice to retrieve the first one, and choiceNumber will contain the index of that item. To retrieve the next one, pass choiceNumber + 1 for atChoice. Repeat this process until -1 is returned for choiceNumber. Also, if no items are selected in the list box, -1 will be returned for choiceNumber.

virtual void GetSelChoiceIndex(
long dialogID,
long itemID,
short inStartIndex,
short& outSelectedIndex)

Parameters

long dialogID No information available.
long itemID No information available.
short inStartIndex No information available.
short& outSelectedIndex No information available.

Version

Availability: from Vectorworks 2009