VCOM:VectorWorks:ISDK::GetProgramVariable

From Vectorworks Developer
Jump to navigation Jump to search

.SDK|SDK ..SDK:Types|SDK Types ..VCOM:VCOM (Vectorworks Component Object Model)|VCOM Basics ..VCOM:Class Reference|VCOM Class Reference

Description

namespace VectorWorks

Member of VCOM:VectorWorks:ISDK

GetProgramVariable returns general program information based on the selector passed. For example, the var2DConvertRes selector would set the short pointed to by result to the 2D conversion resolution. If the selector is not recognized, result is unchanged and false is returned. A list of recognized selectors is found in MiniCadCallBacks.h.

virtual bool GetProgramVariable(
short variableSelector,
void* result)

Parameters

short variableSelector No information available.
void* result No information available.

Return Value

On error returns: false

Version

Availability: from Vectorworks 2009