VCOM:VectorWorks:ISDK::GetParameterOnNurbsCurve

From Vectorworks Developer
Jump to navigation Jump to search

.SDK|SDK ..SDK:Types|SDK Types ..VCOM:VCOM (Vectorworks Component Object Model)|VCOM Basics ..VCOM:Class Reference|VCOM Class Reference

Description

namespace VectorWorks

Member of VCOM:VectorWorks:ISDK

Given a NURBS curve handle and a point(in world space), this function returns the parameter of the point obtained by projecting the input point. The function also returns the index of the piece in the piecewise NURRBS curve on which the projected point lies.

virtual bool GetParameterOnNurbsCurve(
MCObjectHandle h,
const WorldPt3& point,
double& parameter,
long& index)

Parameters

MCObjectHandle h No information available.
constWorldPt3& point No information available.
double& parameter No information available.
long& index No information available.

Return Value

On error returns: false

Version

Availability: from Vectorworks 2009