VCOM:VectorWorks:ISDK::GetNumberOfComponents

From Vectorworks Developer
Jump to navigation Jump to search

.SDK|SDK ..SDK:Types|SDK Types ..VCOM:VCOM (Vectorworks Component Object Model)|VCOM Basics ..VCOM:Class Reference|VCOM Class Reference

Description

namespace VectorWorks

Member of VCOM:VectorWorks:ISDK

Gets the number of components in an object.

virtual Boolean VCOM_CALLTYPE GetNumberOfComponents(
MCObjectHandle object,
short& numComponents) = 0;

Parameters

object MCObjectHandle The object. Can be a wall, round wall, slab, Wall Style, Slab Style, the Wall Preferences, or the Slab Preferences.
numComponents short& Returns the number of components.

Version

Availability: from Vectorworks 2009