VCOM:VectorWorks:ISDK::GetLayoutDialogPosition

From Vectorworks Developer
Jump to navigation Jump to search

.SDK|SDK ..SDK:Types|SDK Types ..VCOM:VCOM (Vectorworks Component Object Model)|VCOM Basics ..VCOM:Class Reference|VCOM Class Reference

Description

namespace VectorWorks

Member of VCOM:VectorWorks:ISDK

Get the screen location of the dialog window, in pixels.

This function will return false if the dialog window does not exist. The dialog window will exist anytime between the Setup message and OK/Cancel message.

virtual bool GetLayoutDialogPosition(
long dialogID,
short& left,
short& top,
short& right,
short& bottom)

Parameters

long dialogID No information available.
short& left No information available.
short& top No information available.
short& right No information available.
short& bottom No information available.

Return Value

On error returns: false

Version

Availability: from Vectorworks 2009