VCOM:VectorWorks:ISDK::GetHatchLevel

From Vectorworks Developer
Jump to navigation Jump to search

.SDK|SDK ..SDK:Types|SDK Types ..VCOM:VCOM (Vectorworks Component Object Model)|VCOM Basics ..VCOM:Class Reference|VCOM Class Reference

Description

namespace VectorWorks

Member of VCOM:VectorWorks:ISDK

Gets the indicated level of the hatch definition to the parameters specified: startPt and repeatVec define a line, dashFactor indicates what fraction of the line is drawn (0.0 to 1.0), offsetVec is an offset from startPt to the next parallel line. The index starts at 0. The number of hatch levels is found with GS_GetObjectVariable(...ovHatchNumLevels...).

virtual CBbool GetHatchLevel(
MCObjectHandle inHatchDef,
short inLevel,
WorldPt& outStartPt,
WorldPt& outRepeatVec,
double& outDashFactor,
WorldPt& outOffsetVec,
ColorRef& outColorIndex,
short& outMilsLineWeight)

Parameters

MCObjectHandle inHatchDef No information available.
short inLevel No information available.
WorldPt& outStartPt No information available.
WorldPt& outRepeatVec No information available.
double& outDashFactor No information available.
WorldPt& outOffsetVec No information available.
ColorRef& outColorIndex No information available.
short& outMilsLineWeight No information available.

Return Value

On error returns: false

Version

Availability: from Vectorworks 2009