VCOM:VectorWorks:ISDK::GetGableAttributes

From Vectorworks Developer
Jump to navigation Jump to search

.SDK|SDK ..SDK:Types|SDK Types ..VCOM:VCOM (Vectorworks Component Object Model)|VCOM Basics ..VCOM:Class Reference|VCOM Class Reference

Description

namespace VectorWorks

Member of VCOM:VectorWorks:ISDK

Get the settings of a gable style dormer. This will fail if the dormerID identifies a dormer of a different style, or the dormerID is not valid.


dormerID: Identifies the dormer for which to retrieve the information.


useHeight: Set to true if the next value is the height of the dormer, if false, next value is the depth (front to back) of the dormer.

heightDepthValue: Size of the dormer, either by height or depth; determined by previous parameter.


bottomWidth: Dimension of bottom front edge of the dormer, left to right.


leftSlope: Angle of left dormer roof.

rightSlope: Angle of right dormer roof.


overhang: Distance roof projects past dormer walls.

virtual bool GetGableAttributes(
MCObjectHandle object,
const short dormerID,
bool& useHeight,
WorldCoord& heightDepthValue,
WorldCoord& bottomWidth,
double_gs& leftSlope,
double_gs& rightSlope,
WorldCoord& overhang)

Parameters

MCObjectHandle object No information available.
constshort dormerID No information available.
bool& useHeight No information available.
WorldCoord& heightDepthValue No information available.
WorldCoord& bottomWidth No information available.
double_gs& leftSlope No information available.
double_gs& rightSlope No information available.
WorldCoord& overhang No information available.

Return Value

On error returns: false

Version

Availability: from Vectorworks 2009