VCOM:VectorWorks:ISDK::GetFolderN

From Vectorworks Developer
Jump to navigation Jump to search

.SDK|SDK ..SDK:Types|SDK Types ..VCOM:VCOM (Vectorworks Component Object Model)|VCOM Basics ..VCOM:Class Reference|VCOM Class Reference

Description

namespace VectorWorks

Member of VCOM:VectorWorks:ISDK

Returns the full path of the folder requested by inWhichFolder. outPath must be a pointer to a buffer of at least 1024 characters. If the requested folder does not exist and inCreateIfMissing is true, then it will be created. Otherwise, it returns false if the folder does not exist.

virtual bool GetFolderN(
FolderSpecifier inWhichFolder,
char outPath[1024],
bool inCreateIfMissing = false)

Parameters

FolderSpecifier inWhichFolder No information available.
char outPath[1024] No information available.
boolinCreateIfMissing= false No information available.

Return Value

On error returns: false

Version

Availability: from Vectorworks 2009