VCOM:VectorWorks:ISDK::GetFilePathInUserRootN

From Vectorworks Developer
Jump to navigation Jump to search

.SDK|SDK ..SDK:Types|SDK Types ..VCOM:VCOM (Vectorworks Component Object Model)|VCOM Basics ..VCOM:Class Reference|VCOM Class Reference

Description

namespace VectorWorks

Member of VCOM:VectorWorks:ISDK

Get the filename in the given folder class under the User Data root. This function is useful for obtaining the paths of files to save out to.

folderClass: One of the folder type constants defined in FolderSpecifiers.h

fileName: The name of the file

outFilePath: The path to the file under the User Data root.

virtual bool GetFilePathInUserRootN(
FolderSpecifier folderClass,
const char* fileName,
char outFilePath[1024])

Parameters

FolderSpecifier folderClass No information available.
constchar* fileName No information available.
char outFilePath[1024] No information available.

Return Value

On error returns: false

Version

Availability: from Vectorworks 2009