VCOM:VectorWorks:ISDK::GetDormerAttributes

From Vectorworks Developer
Jump to navigation Jump to search

.SDK|SDK ..SDK:Types|SDK Types ..VCOM:VCOM (Vectorworks Component Object Model)|VCOM Basics ..VCOM:Class Reference|VCOM Class Reference

Description

namespace VectorWorks

Member of VCOM:VectorWorks:ISDK

Get the common settings for all dormers. This will fail if the dormerID identifies a skylight, or dormerID is not valid.


dormerID: Identifies the dormer for which to retrieve the information.

edgeIndex: Index to which roof face this skylight is placed. Value is one based.


cornerOffset: Distance from the vertex to the center of the dormer.

isPerpOffset: Determines the meaning of the next parameter. Set to true for the value to be the plan distance from the outline to the front of the dormer. Set to false for offsetValue to set the distance from the top of the dormer to the bearing height.

perpOrHeightOffset: Either the distance from the outline to the front of the dormer, or from the dormer roof to the floor.


symName: Symbol to place in the dormer, this is the window.

centerSymbol: Set to true to vertically center the symbol in the dormer. Doing so causes the next parameter to be ignored.

Set to false to offset the symbol from the top of the dormer using the next parameter.

symOffset: Distance from top of the dormer to symbol insertion point.

virtual bool GetDormerAttributes(
MCObjectHandle object,
const short dormerID,
short& edgeIndex,
WorldCoord& cornerOffset,
bool& isPerpOffset,
WorldCoord& perpOrHeightOffset,
InternalIndex& symName,
bool& centerSymbol,
WorldCoord& symOffset)

Parameters

MCObjectHandle object No information available.
constshort dormerID No information available.
short& edgeIndex No information available.
WorldCoord& cornerOffset No information available.
bool& isPerpOffset No information available.
WorldCoord& perpOrHeightOffset No information available.
InternalIndex& symName No information available.
bool& centerSymbol No information available.
WorldCoord& symOffset No information available.

Return Value

On error returns: false

Version

Availability: from Vectorworks 2009