VCOM:VectorWorks:ISDK::GetDistanceAlongNurbsCurve

From Vectorworks Developer
Jump to navigation Jump to search

.SDK|SDK ..SDK:Types|SDK Types ..VCOM:VCOM (Vectorworks Component Object Model)|VCOM Basics ..VCOM:Class Reference|VCOM Class Reference

Description

namespace VectorWorks

Member of VCOM:VectorWorks:ISDK

Gets distance between a point at parameter1 on the curve piece index1 and another point at parameter2 on the curve piece with index2

virtual bool GetDistanceAlongNurbsCurve(
MCObjectHandle inNurbsCurve,
double_param inParameter1,
long inParameter1CurveIndex,
double_param inParameter2,
long inParameter2CurveIndex,
double_gs& outDistance)

Parameters

MCObjectHandle inNurbsCurve No information available.
double_param inParameter1 No information available.
long inParameter1CurveIndex No information available.
double_param inParameter2 No information available.
long inParameter2CurveIndex No information available.
double_gs& outDistance No information available.

Return Value

On error returns: false

Version

Availability: from Vectorworks 2009