VCOM:VectorWorks:ISDK::GetDXFColorToLineWeight

From Vectorworks Developer
Jump to navigation Jump to search

.SDK|SDK ..SDK:Types|SDK Types ..VCOM:VCOM (Vectorworks Component Object Model)|VCOM Basics ..VCOM:Class Reference|VCOM Class Reference

Description

namespace VectorWorks

Member of VCOM:VectorWorks:ISDK

Given a valid DXF color index from 0 to 255 (0 = kDXFColorByBlock), the lineweight in mils that the color maps to is returned. This map is used to initialize the mapping dialog on import, and to control mapping when doing a silent import with GS_ImportDXFMac() or GS_ImportDXFWin(). If that color index is not currently being mapped to a lineweight, kUnmappedLineWeight is returned. During DXF import, any unmapped values will be set to a default value. To set the mapping, use GS_SetDXFColorToLineWeight(). Constants for standard colors (kDXFCyan, etc) are defined in MiniCadCallBacks.h.

virtual short GetDXFColorToLineWeight(
const short inDXFColorIndex)

Parameters

constshort inDXFColorIndex No information available.

Return Value

On error returns: kUnmappedLineWeight

Version

Availability: from Vectorworks 2009