VCOM:VectorWorks:ISDK::GetComponentWidth

From Vectorworks Developer
Jump to navigation Jump to search

.SDK|SDK ..SDK:Types|SDK Types ..VCOM:VCOM (Vectorworks Component Object Model)|VCOM Basics ..VCOM:Class Reference|VCOM Class Reference

Description

namespace VectorWorks

Member of VCOM:VectorWorks:ISDK

Gets the width of a component in an object.

virtual Boolean VCOM_CALLTYPE GetComponentWidth(
MCObjectHandle object,
short componentIndex,
WorldCoord& width) = 0;

Parameters

object MCObjectHandle The object. Can be a wall, round wall, slab, Wall Style, Slab Style, the Wall Preferences, or the Slab Preferences.
componentIndex short The index of the component.
width WorldCoord& Returns the width of the component.

Version

Availability: from Vectorworks 2009