VCOM:VectorWorks:ISDK::GetComponentUseFillClassAttr

From Vectorworks Developer
Jump to navigation Jump to search

.SDK|SDK ..SDK:Types|SDK Types ..VCOM:VCOM (Vectorworks Component Object Model)|VCOM Basics ..VCOM:Class Reference|VCOM Class Reference

Description

namespace VectorWorks

Member of VCOM:VectorWorks:ISDK

Gets the use fill class attributes flag of a component in an object.

virtual Boolean VCOM_CALLTYPE GetComponentUseFillClassAttr(
MCObjectHandle object,
short componentIndex,
Boolean& useFillClassAttributes) = 0;

Parameters

object MCObjectHandle The object. Can be a wall, round wall, slab, Wall Style, Slab Style, the Wall Preferences, or the Slab Preferences.
componentIndex short The index of the component.
useFillClassAttributes Boolean& Returns whether or not the component is using class attributes for its fill.

Version

Availability: from Vectorworks 2009