VCOM:VectorWorks:ISDK::GetComponentOffsetFromWallBottom

From Vectorworks Developer
Jump to navigation Jump to search

.SDK|SDK ..SDK:Types|SDK Types ..VCOM:VCOM (Vectorworks Component Object Model)|VCOM Basics ..VCOM:Class Reference|VCOM Class Reference

Description

namespace VectorWorks

Member of VCOM:VectorWorks:ISDK

Gets the offset from wall bottom of a component in an object.

virtual Boolean VCOM_CALLTYPE GetComponentOffsetFromWallBottom(
MCObjectHandle object,
short componentIndex,
WorldCoord& offsetFromWallBottom) = 0;

Parameters

object MCObjectHandle The object. Can be a wall, round wall, Wall Style, or the Wall Preferences.
componentIndex short The index of the component.
offsetFromWallBottom WorldCoord& Returns the offset from wall bottom of the component.

Version

Availability: from Vectorworks 2010