VCOM:VectorWorks:ISDK::GetComponentFollowBottomWallPeaks

From Vectorworks Developer
Jump to navigation Jump to search

.SDK|SDK ..SDK:Types|SDK Types ..VCOM:VCOM (Vectorworks Component Object Model)|VCOM Basics ..VCOM:Class Reference|VCOM Class Reference

Description

namespace VectorWorks

Member of VCOM:VectorWorks:ISDK

Gets the follow bottom wall peaks flag of a component in an object.

virtual Boolean VCOM_CALLTYPE GetComponentFollowBottomWallPeaks(
MCObjectHandle object,
short componentIndex,
Boolean& followBottomWallPeaks) = 0;

Parameters

object MCObjectHandle The object. Can be a wall, round wall, Wall Style, or the Wall Preferences.
componentIndex short The index of the component.
followBottomWallPeaks Boolean& Returns whether or not the component is following bottom wall peaks.

Version

Availability: from Vectorworks 2010