VCOM:VectorWorks:ISDK::GetBatAttributes

From Vectorworks Developer
Jump to navigation Jump to search

.SDK|SDK ..SDK:Types|SDK Types ..VCOM:VCOM (Vectorworks Component Object Model)|VCOM Basics ..VCOM:Class Reference|VCOM Class Reference

Description

namespace VectorWorks

Member of VCOM:VectorWorks:ISDK

Get the settings of a bat style dormer. This will fail if the dormerID identifies a dormer of a different style, or the dormerID is not valid.


dormerID: Identifies the dormer for which to retrieve the information.


useHeight: Set to true if the next value is the height of the dormer, if false, next value is the depth (front to back) of the dormer.

heightDepthValue: Size of the dormer, either by height or depth; determined by previous parameter.


bottomWidth: Dimension of bottom front edge of the dormer, left to right.

baseHeight: Dimension of the bottom half of the dormer.

topWidth: Dimension of the roof of the dormer.


topSlope: Angle of the dormer roof.


controlPoint: The distance from the side to where the curve starts. Must be less than (bottomWidth - topWidth) / 2.

virtual bool GetBatAttributes(
MCObjectHandle object,
const short dormerID,
bool& useHeight,
WorldCoord& heightDepthValue,
WorldCoord& bottomWidth,
WorldCoord& topWidth,
WorldCoord& baseHeight,
double_gs& topSlope,
WorldCoord& controlPoint)

Parameters

MCObjectHandle object No information available.
constshort dormerID No information available.
bool& useHeight No information available.
WorldCoord& heightDepthValue No information available.
WorldCoord& bottomWidth No information available.
WorldCoord& topWidth No information available.
WorldCoord& baseHeight No information available.
double_gs& topSlope No information available.
WorldCoord& controlPoint No information available.

Return Value

On error returns: false

Version

Availability: from Vectorworks 2009