VCOM:VectorWorks:ISDK::GetActiveDocumentN

From Vectorworks Developer
Jump to navigation Jump to search

.SDK|SDK ..SDK:Types|SDK Types ..VCOM:VCOM (Vectorworks Component Object Model)|VCOM Basics ..VCOM:Class Reference|VCOM Class Reference

Description

namespace VectorWorks

Member of VCOM:VectorWorks:ISDK

Returns the path of the active VectorWorks document. The return value is false if there is no open document. The saved parameter indicates whether the document has been saved to disk. If it has not, then activeDocumentPath is only a file name.

virtual bool GetActiveDocumentN(
char activeDocumentPath[1024],
bool& saved)

Parameters

char activeDocumentPath[1024] No information available.
bool& saved No information available.

Return Value

On error returns: false

Version

Availability: from Vectorworks 2009