VCOM:VectorWorks:ISDK::GenerateBezierApproximationFromPolygon

From Vectorworks Developer
Jump to navigation Jump to search

.SDK|SDK ..SDK:Types|SDK Types ..VCOM:VCOM (Vectorworks Component Object Model)|VCOM Basics ..VCOM:Class Reference|VCOM Class Reference

Description

namespace VectorWorks

Member of VCOM:VectorWorks:ISDK

Generates a quadratic Bezier curve approximation of the path represented by the constituent vertices of the referenced polygon object.

virtual MCObjectHandle GenerateBezierApproximationFromPolygon(
MCObjectHandle hPolygonHandle,
const WorldCoord approximationTolerance,
const double discontinuityAngleTolerance,
const unsigned short quadraticsPerCubic)

Parameters

MCObjectHandle hPolygonHandle No information available.
constWorldCoord approximationTolerance No information available.
constdouble discontinuityAngleTolerance No information available.
constunsignedshort quadraticsPerCubic No information available.

Return Value

On error returns: false

Version

Availability: from Vectorworks 2009