VCOM:VectorWorks:ISDK::GSGetResourceString

From Vectorworks Developer
Jump to navigation Jump to search

.SDK|SDK ..SDK:Types|SDK Types ..VCOM:VCOM (Vectorworks Component Object Model)|VCOM Basics ..VCOM:Class Reference|VCOM Class Reference

Description

namespace VectorWorks

Member of VCOM:VectorWorks:ISDK

Retrieves the string specified by id and index from a 'STR#' resource. If lookOnlyInCurrentFile is true, then the call will look only in your external's resources, otherwise the call will first look in your external's resources and then in MiniCAD's resources for the requested resource. External developers are strongly discouraged from passing false in lookOnlyInCurrentFile. Resources in the VectorWorks application are not documented and may change without notice. lookOnlyInCurrentFile may disappear in future versions of the SDK.


If the requested string does not exist, then theString is assigned an empty string.


debugWarning allows internal ASSERT warnings about empty strings to be silenced. It can be ignored by developers outside NNA.

virtual void GSGetResourceString(
short id,
short index,
const TXString& theString,
bool lookOnlyInCurrentFile = true,
EEmptyStringResourceHandling debugWarning = eWarnAboutEmptyStringResult)

Parameters

short id No information available.
short index No information available.
constTXString& theString No information available.
boollookOnlyInCurrentFile= true No information available.
EEmptyStringResourceHandlingdebugWarning= eWarnAboutEmptyStringResult No information available.

Version

Availability: from Vectorworks 2009