VCOM:VectorWorks:ISDK::ForEachFileInStandardFolder

From Vectorworks Developer
Jump to navigation Jump to search

.SDK|SDK ..SDK:Types|SDK Types ..VCOM:VCOM (Vectorworks Component Object Model)|VCOM Basics ..VCOM:Class Reference|VCOM Class Reference

Description

namespace VectorWorks

Member of VCOM:VectorWorks:ISDK

For each file in the folder class, calls a given function 'processFile'.

The files are given in alphabetical order, regardless of their physical location on the filesystem.

If a file with the same name occurs more than once in the search path, only the first occurrence will be returned.

Each file passed into the callback is guaranteed to exist at that moment, so its existence may not need to be rechecked.

The interface for this function is designed to closely match ForEachFileInFolder.

'folderSpec' is one of the folder constants defined in FolderSpecifiers.h

virtual EForEachFileResult ForEachFileInStandardFolder(
GS_ForEachFilePathProcPtr processFile,
EFolderSpecifier folderSpec,
void* env)

Parameters

GS_ForEachFilePathProcPtr processFile No information available.
EFolderSpecifier folderSpec No information available.
void* env No information available.

Return Value

On error returns: kFolderNotFoundError

Remarks

typedef EForEachFileResult (*GS_ForEachFilePathNProcPtr)(
const char* fullPath,
const char* fileName,
const char* fileExtension,
CallBackPtr cbp,
void* env);

You may consider using VCOM:VectorWorks:Filing:IApplicationFolders.

Version

Availability: from Vectorworks 2009

See Also

VCOM:VectorWorks:Filing:IApplicationFolders

[[VCOM:VectorWorks:Filing:IApplicationFolders]]