VCOM:VectorWorks:ISDK::ForEachBreak

From Vectorworks Developer
Jump to navigation Jump to search

.SDK|SDK ..SDK:Types|SDK Types ..VCOM:VCOM (Vectorworks Component Object Model)|VCOM Basics ..VCOM:Class Reference|VCOM Class Reference

Description

namespace VectorWorks

Member of VCOM:VectorWorks:ISDK

typedef Boolean (*ForEachBreakProcPtr)(Handle h, long index, Coord off, long breakType, void* breakData, CallBackPtr cbp, void* env);


Steps through each break in a wall and calls the action procedure until all breaks have been passed or true is returned from the action procedure. off is the distance along the Wall, starting at the first point, that the break lies. Depending upon the breakType, breakData can point to one of the following records: SymbolBreakType, HalfBreakType, CapBreakType, or PeakBreakType.

virtual void ForEachBreak(
MCObjectHandle theWall,
GS_ForEachBreakProcPtr action,
void* actionEnv)

Parameters

MCObjectHandle theWall No information available.
GS_ForEachBreakProcPtr action No information available.
void* actionEnv No information available.

Version

Availability: from Vectorworks 2009