VCOM:VectorWorks:ISDK::FontNameFromIndex

From Vectorworks Developer
Jump to navigation Jump to search

.SDK|SDK ..SDK:Types|SDK Types ..VCOM:VCOM (Vectorworks Component Object Model)|VCOM Basics ..VCOM:Class Reference|VCOM Class Reference

Description

namespace VectorWorks

Member of VCOM:VectorWorks:ISDK

MiniCAD specifies fonts by an internal index which is specific to the active MiniCAD file. FontNameFromIndex allows the name of the font to be retrieved given an index. If useMappingTable is true, then the name of the font actually used to draw text on this system is returned. This takes the user's font mapping into account, and the font name returned will be present on your system, but may not correspond to the font originally specified for this object. If useMappingTable is false, then the name of the font originally assigned will be returned and there is a significant chance that the font will not be present on your system.

virtual void FontNameFromIndex(
short fontIndex,
const TXString& fontName,
bool useMappingTable)

Parameters

short fontIndex No information available.
constTXString& fontName No information available.
bool useMappingTable No information available.

Version

Availability: from Vectorworks 2009