VCOM:VectorWorks:ISDK::FindDataObject

From Vectorworks Developer
Jump to navigation Jump to search

.SDK|SDK ..SDK:Types|SDK Types ..VCOM:VCOM (Vectorworks Component Object Model)|VCOM Basics ..VCOM:Class Reference|VCOM Class Reference

Description

namespace VectorWorks

Member of VCOM:VectorWorks:ISDK

FindDataObject will return the first data object attached to owner that has the specified tag. A tag of '****' will match any data object.

If you only need to find one instance of a data object (if, for example, you know that only one should exist), use this:

MCObjectHandle auxObjectHd;
if ((auxObjectHd = gSDK->FindDataObject(owner, myTag)) != nil) {
    // do something with auxObjectHd
}
virtual MCObjectHandle FindDataObject(
MCObjectHandle owner,
OSType tag)

Parameters

MCObjectHandle owner No information available.
OSType tag No information available.

Return Value

On error returns: nil

Version

Availability: from Vectorworks 2009