VCOM:VectorWorks:ISDK::ExternalNameToID

From Vectorworks Developer
Jump to navigation Jump to search

.SDK|SDK ..SDK:Types|SDK Types ..VCOM:VCOM (Vectorworks Component Object Model)|VCOM Basics ..VCOM:Class Reference|VCOM Class Reference

Description

namespace VectorWorks

Member of VCOM:VectorWorks:ISDK

This returns the ID of an external library file, allowing it to be called by the XCALL interface which takes an ID. It is faster than calling an external by file name.

virtual long ExternalNameToID(
const TXString& fnName)

Parameters

constTXString& fnName No information available.

Return Value

On error returns: -1

Version

Availability: from Vectorworks 2009