VCOM:VectorWorks:ISDK::ExtendNurbsSurface

From Vectorworks Developer
Jump to navigation Jump to search

.SDK|SDK ..SDK:Types|SDK Types ..VCOM:VCOM (Vectorworks Component Object Model)|VCOM Basics ..VCOM:Class Reference|VCOM Class Reference

Description

namespace VectorWorks

Member of VCOM:VectorWorks:ISDK

Extends a surface by a given distance at the start or the end of the U direction or V direction. The extension can either be linear or can continue the curvature of the edge of the surface.

virtual MCObjectHandle ExtendNurbsSurface(
MCObjectHandle surfaceHandle,
double_param distance,
bool bStart,
bool bLinear,
bool bUDir)

Parameters

MCObjectHandle surfaceHandle No information available.
double_param distance No information available.
bool bStart No information available.
bool bLinear No information available.
bool bUDir No information available.

Return Value

On error returns: nil

Version

Availability: from Vectorworks 2009