VCOM:VectorWorks:ISDK::EncryptVSPluginFilePath

From Vectorworks Developer
Jump to navigation Jump to search

.SDK|SDK ..SDK:Types|SDK Types ..VCOM:VCOM (Vectorworks Component Object Model)|VCOM Basics ..VCOM:Class Reference|VCOM Class Reference

Description

namespace VectorWorks

Member of VCOM:VectorWorks:ISDK

Encrypt the specified VectorScript Plug-in file. For use by a batch-encryption plug-in.

virtual bool VCOM_CALLTYPE EncryptVSPluginFile(
IFileIdentifier* pPluginFileID,
bool doObfuscation = true) = 0;

Parameters

pPluginFileID IFileIdentifier* The VectorScript file that is to be encripted
doObfuscation bool <no info>

Version

Availability: from Vectorworks 2009