VCOM:VectorWorks:ISDK::DoMenuName

From Vectorworks Developer
Jump to navigation Jump to search

.SDK|SDK ..SDK:Types|SDK Types ..VCOM:VCOM (Vectorworks Component Object Model)|VCOM Basics ..VCOM:Class Reference|VCOM Class Reference

Description

namespace VectorWorks

Member of VCOM:VectorWorks:ISDK

Executes the menu specified by name. Calls menu items by the name of the external menu file or the name of the internal MITM resource. Using the file and resource names allows externals to work on any localized version of MiniCad. If the name is a chunk, then the chunkIndex should be the number of the item in the chunk to execute. If the item is not a chunk then 0 must be passed in chunkIndex. DoMenuName can be called recursively.

virtual short DoMenuName(
const TXString& name,
short chunkIndex)

Parameters

constTXString& name No information available.
short chunkIndex No information available.

Return Value

Return values:

  • kMCMenuNoErr = 0
  • kMCMenuInvalidChunkIndex = -1
  • kMCMenuInvalidCommandID = -2
  • kMCMenuInvalidHashIndex = -3
  • kMCMenuInternalMenuError = -4
  • kMCMenuNullCommand = -5
  • kMCMenuHashTableError = -6
  • kMCMenuExternalMenuError = -7
  • kMCMenuMenuItemDisabled = -8
  • kMCMenuMenuExistsErr = -9
  • kMCMenuAllocateErr = -10
  • kMCMenuMenuNotFound = -11
  • kMCMenuMenuDefFunctionError = -12
  • kMCMenuWorksheetMenuNotAvail = -13
  • kMCMenuDisabledForSecurity = -14

Version

Availability: from Vectorworks 2009