VCOM:VectorWorks:ISDK::DefineCustomObject

From Vectorworks Developer
Jump to navigation Jump to search

.SDK|SDK ..SDK:Types|SDK Types ..VCOM:VCOM (Vectorworks Component Object Model)|VCOM Basics ..VCOM:Class Reference|VCOM Class Reference

Description

namespace VectorWorks

Member of VCOM:VectorWorks:ISDK

Look for a FormatNode which defines the custom object specified by the name argument. If it does not exist, create a FormatNode based on definition in resource file. Also create a RecordNode with default parameter values. The prefWhen argument determines if a dialog is presented: 0 means never, 1 means always, and 2 means only if we just created a new FormatNode. The dialog allows the user to set the default parameter values. Returns handle to CustomObject FormatNode.

virtual MCObjectHandle DefineCustomObject(
const InternalName name,
Byte prefWhen = kCustomObjectPrefAlways)

Parameters

constInternalName name No information available.
Byte prefWhen=kCustomObjectPrefAlways No information available.

Return Value

On error returns: nil

Version

Availability: from Vectorworks 2009