VCOM:VectorWorks:ISDK::CustomObjectControlPtSet

From Vectorworks Developer
Jump to navigation Jump to search

.SDK|SDK ..SDK:Types|SDK Types ..VCOM:VCOM (Vectorworks Component Object Model)|VCOM Basics ..VCOM:Class Reference|VCOM Class Reference

Description

namespace VectorWorks

Member of VCOM:VectorWorks:ISDK

Sets the specified Control Point properties. Must follow a successfull call to CustomObjectControlPtsCreate. dataIndex is a zero based index specifying the Control Point to be set. False is returned if index is out of range or if called on an object type other than a kParametricNode.

virtual bool CustomObjectControlPtSet(
MCObjectHandle inOwnerObj,
int dataIndex,
const WorldPt3& pt,
bool is2DOnly,
bool isHidden,
int inClientID)

Parameters

MCObjectHandle inOwnerObj No information available.
int dataIndex No information available.
const WorldPt3& pt No information available.
bool is2DOnly No information available.
bool isHidden No information available.
int inClientID No information available.

Return Value

On error returns: false

Version

Availability: from Vectorworks 2009