VCOM:VectorWorks:ISDK::CreateTextBlock

From Vectorworks Developer
Jump to navigation Jump to search

.SDK|SDK ..SDK:Types|SDK Types ..VCOM:VCOM (Vectorworks Component Object Model)|VCOM Basics ..VCOM:Class Reference|VCOM Class Reference

Description

namespace VectorWorks

Member of VCOM:VectorWorks:ISDK

Creates a text block at location textOrigin with the string textStr using the current defaults for font, size, style, and color. If fixedSize is true, width determines the static width of the text box and text is dynamically wrapped to that width; otherwise lines break only on carraige returns in the text.

virtual MCObjectHandle CreateTextBlock(
const TXString& textStr,
const WorldPt& textOrigin,
bool fixedSize,
WorldCoord width)

Parameters

const TXString& textStr No information available.
const WorldPt& textOrigin No information available.
bool fixedSize No information available.
WorldCoord width No information available.

Return Value

On error returns: nil

Version

Availability: from Vectorworks 2009