VCOM:VectorWorks:ISDK::CreateSymbolDefinition

From Vectorworks Developer
Jump to navigation Jump to search

.SDK|SDK ..SDK:Types|SDK Types ..VCOM:VCOM (Vectorworks Component Object Model)|VCOM Basics ..VCOM:Class Reference|VCOM Class Reference

Description

namespace VectorWorks

Member of VCOM:VectorWorks:ISDK

Creates and returns a handle to a new symbol definition object. You may add objects to the definition either by using AddObjectToContainer, InsertObjectBefore, or InsertObjectAfter or by calling EnterContainer on the returned handle. [See the manual entries for these functions for more details.] Function returns nil if the name is already in use.

virtual MCObjectHandle CreateSymbolDefinition(
const InternalName name)

Parameters

constInternalName name No information available.

Return Value

On error returns: nil

Version

Availability: from Vectorworks 2009