VCOM:VectorWorks:ISDK::CreateListBox

From Vectorworks Developer
Jump to navigation Jump to search

.SDK|SDK ..SDK:Types|SDK Types ..VCOM:VCOM (Vectorworks Component Object Model)|VCOM Basics ..VCOM:Class Reference|VCOM Class Reference

Description

namespace VectorWorks

Member of VCOM:VectorWorks:ISDK

Creates a layout manager list box with the given itemID.


Event handling:

When an item is selected the itemID equals list boxes ID and the data field contains the index of the selected item.

When an item is double clicked the itemID equals the negative of the list box ID and the data field contains the index of the selected item.

virtual void CreateListBox(
long dialogID,
long itemID,
short widthInCharacters,
short heightInCharacters)

Parameters

long dialogID No information available.
long itemID No information available.
short widthInCharacters No information available.
short heightInCharacters No information available.

Version

Availability: from Vectorworks 2009