VCOM:VectorWorks:ISDK::CreateLightN

From Vectorworks Developer
Jump to navigation Jump to search

.SDK|SDK ..SDK:Types|SDK Types ..VCOM:VCOM (Vectorworks Component Object Model)|VCOM Basics ..VCOM:Class Reference|VCOM Class Reference

Description

namespace VectorWorks

Member of VCOM:VectorWorks:ISDK

Creates and returns a new light with the specified position, kind (kDirectionalLight | kPointLight | kSpotLight), and basic light data. The light is created as the topmost object in the current layer. This routine returns nil if the creation fails.

virtual MCObjectHandle CreateLightN(
const WorldPt3& pos,
short kind,
bool isOn,
double_param brightness,
const WorldPt3& color,
bool castShadows)

Parameters

constWorldPt3& pos No information available.
short kind No information available.
bool isOn No information available.
double_param brightness No information available.
constWorldPt3& color No information available.
bool castShadows No information available.

Return Value

On error returns: nil

Version

Availability: from Vectorworks 2009