VCOM:VectorWorks:ISDK::CreateLayout

From Vectorworks Developer
Jump to navigation Jump to search

.SDK|SDK ..SDK:Types|SDK Types ..VCOM:VCOM (Vectorworks Component Object Model)|VCOM Basics ..VCOM:Class Reference|VCOM Class Reference

Description

namespace VectorWorks

Member of VCOM:VectorWorks:ISDK

creates a layout manager dialog and returns a dialog ID

hasHelp - pass true to create a dialog help box along the bottom of the dialog

defaultButtonName & cancelButtonName - if the string is non nil, creates a button with ID equal to 1 or 2 respectively. These buttons always appear in the bottom right corner of the dialog, and they are always placed in the order that is appropriate for a particular platform. For custom placement of the default and cancel buttons, pass nil in this routine and use the standard routines to create and place buttons with ID's equal to 1 or 2.

virtual long CreateLayout(
const TXString& dialogTitle,
bool hasHelp,
const TXString& defaultButtonName,
const TXString& cancelButtonName)

Parameters

constTXString& dialogTitle No information available.
bool hasHelp No information available.
constTXString& defaultButtonName No information available.
constTXString& cancelButtonName No information available.

Return Value

On error returns: 0

Version

Availability: from Vectorworks 2009