VCOM:VectorWorks:ISDK::CreateGroupBox

From Vectorworks Developer
Jump to navigation Jump to search

.SDK|SDK ..SDK:Types|SDK Types ..VCOM:VCOM (Vectorworks Component Object Model)|VCOM Basics ..VCOM:Class Reference|VCOM Class Reference

Description

namespace VectorWorks

Member of VCOM:VectorWorks:ISDK

Creates a layout manager group box with the given itemID.

name - leave blank to create box with no name

hasFrame - set to false to create a logical grouping.

For dialogs with more than one radio button group, each radio button group must have its own group box, but the group box does not have to have a frame.


Event handling:

Group boxes do not generate events.

virtual void CreateGroupBox(
long dialogID,
long itemID,
const TXString& name,
bool hasFrame)

Parameters

long dialogID No information available.
long itemID No information available.
constTXString& name No information available.
bool hasFrame No information available.

Version

Availability: from Vectorworks 2009