VCOM:VectorWorks:ISDK::CreateEditReal

From Vectorworks Developer
Jump to navigation Jump to search

.SDK|SDK ..SDK:Types|SDK Types ..VCOM:VCOM (Vectorworks Component Object Model)|VCOM Basics ..VCOM:Class Reference|VCOM Class Reference

Description

namespace VectorWorks

Member of VCOM:VectorWorks:ISDK

Edits real values. Allows usits and math calculations to be entered in edit field. There are 5 edit real types: 1 - Real, regular old real type; 2 - Angle, SDK input and output is always in degrees but display and user input is based on documents Unit settings; 3 - Dimension, usually an offset this is a distance that is not tied to the origin; 4 - CoordinateX, this is an exact x location on the drawing; 5- CoordinateY, this is an exact y location on the drawing. There are separate x and y controls to account for changes the user may make to the origin. Z coordinates should use the offset mode.

virtual void CreateEditReal(
long dialogID,
long itemID,
long editRealType,
double value,
short widthInCharacters)

Parameters

long dialogID No information available.
long itemID No information available.
long editRealType No information available.
double value No information available.
short widthInCharacters No information available.

Version

Availability: from Vectorworks 2009