VCOM:VectorWorks:ISDK::CreateCustomObjectDoubleClick

From Vectorworks Developer
Jump to navigation Jump to search

.SDK|SDK ..SDK:Types|SDK Types ..VCOM:VCOM (Vectorworks Component Object Model)|VCOM Basics ..VCOM:Class Reference|VCOM Class Reference

Description

namespace VectorWorks

Member of VCOM:VectorWorks:ISDK

Displays an object creation dialog which enables the creation of an instance of the CustomObject specified by the name argument.

Location and orientation are defined by the dialog.

Calls ISDK::DefineCustomObject first to either find the defining FormatNode or create it.

virtual MCObjectHandle CreateCustomObjectDoubleClick(
const InternalName name)

Parameters

constInternalName name No information available.

Return Value

Returns handle to Object.

On error returns: nil

Version

Availability: from Vectorworks 2009