VCOM:VectorWorks:ISDK::CreateBasicSlab

From Vectorworks Developer
Jump to navigation Jump to search

.SDK|SDK ..SDK:Types|SDK Types ..VCOM:VCOM (Vectorworks Component Object Model)|VCOM Basics ..VCOM:Class Reference|VCOM Class Reference

Description

namespace VectorWorks

Member of VCOM:VectorWorks:ISDK

Creates a basic slab of the specified slab kind. Call SetObjectVariable to fill in the properties for the basic slab object (all constants start with ovSlab...). Basic slabs are container objects; after creating the basic slab add objects to the container to give it shape.

virtual MCObjectHandle VCOM_CALLTYPE CreateBasicSlab(
short slabKind);

Parameters

slabKind short The slab kind. 1 - Roof, 2 - Floor, 3 - Column

Return Value

The basic slab.

Remarks

This function does what CreateSlab did in Vectorworks 2010 and earlier. In Vectorworks 2011 CreateSlab creates the type of slab object that is new to Vectorworks 2011.

Version

Availability: from Vectorworks 2010