VCOM:VectorWorks:ISDK::ConvertToPolyline

From Vectorworks Developer
Jump to navigation Jump to search

.SDK|SDK ..SDK:Types|SDK Types ..VCOM:VCOM (Vectorworks Component Object Model)|VCOM Basics ..VCOM:Class Reference|VCOM Class Reference

Description

namespace VectorWorks

Member of VCOM:VectorWorks:ISDK

Just like ConvertToPolygon, but makes a polyline object instead. Polylines yield smoother results for curved objects (ellipses, arcs, &c.) but are more difficult to manipulate in certain ways than polygons.

virtual MCObjectHandle ConvertToPolyline(
MCObjectHandle h,
bool preserveOriginal = false)

Parameters

MCObjectHandle h No information available.
bool preserveOriginal=false No information available.

Return Value

On error returns: nil

Version

Availability: from Vectorworks 2009