VCOM:VectorWorks:ISDK::ConvertTo3DPolygons

From Vectorworks Developer
Jump to navigation Jump to search

.SDK|SDK ..SDK:Types|SDK Types ..VCOM:VCOM (Vectorworks Component Object Model)|VCOM Basics ..VCOM:Class Reference|VCOM Class Reference

Description

namespace VectorWorks

Member of VCOM:VectorWorks:ISDK

Creates and returns a handle to a new 3D polygon object which is h converted to a group of 3D polygons. By default, the new polygonized object replaces the original, but if preserveOriginal is true, the polygonized object is created as the frontmost object in the current layer. Note that not all objects can be converted to a polygon, so the type of the objects returned may not be qPolyNode. In particular, loci, text, bitmaps, picts, and on-drawing worksheets are not converted.

virtual MCObjectHandle ConvertTo3DPolygons(
MCObjectHandle h,
bool preserveOriginal = false)

Parameters

MCObjectHandle h No information available.
boolpreserveOriginal= false No information available.

Return Value

On error returns: nil

Version

Availability: from Vectorworks 2009