VCOM:VectorWorks:ISDK::Confirm

From Vectorworks Developer
Jump to navigation Jump to search

.SDK|SDK ..SDK:Types|SDK Types ..VCOM:VCOM (Vectorworks Component Object Model)|VCOM Basics ..VCOM:Class Reference|VCOM Class Reference

Description

namespace VectorWorks

Member of VCOM:VectorWorks:ISDK

Posts a confirmation dialog with the specified message and two buttons. If yesOrNo is false, the buttons are labeled OK and Cancel, if it is true, they read Yes and No instead. Returns 1 if the user clicks OK (or Yes) and 0 if they click Cancel (or No).

virtual bool Confirm(
short strListID,
short index,
bool yesOrNo)

Parameters

short strListID No information available.
short index No information available.
bool yesOrNo No information available.

Return Value

On error returns: false

Version

Availability: from Vectorworks 2009